Creative 3D modeling, texturing and rendering tools for Windows PC

Modo

Join our mailing list

Stay up to date with latest software releases, news, software discounts, deals and more.

Subscribe
Download Modo 14.1

Modo

 -  100% Safe  -  Trial

What's new in this version:

Bug-Fixes:
- Deleting filtered items in the item list using the Delete key did not display a warning
- Exiting Slave Mode caused Modo to crash
- Iridescence Materials did not work with Group Masks in the Shader Tree
- Viewport interaction was slow compared to previous versions of Modo
- UV handle positions ignored the aspect ratio of the image
- Expanding the Modo interface immediately after scene load with the pointer over the Shader Tree caused Modo to crash
- Enabling Use Image Ratio in the UV view places snapping and element action centers incorrectly
- The Modo introduction screen was occasionally blank on start-up
- Calling sel.hide() or sel.unhide() in a Python script caused Modo to crash
- AVP: Multiple shader groups made viewport interaction sluggish
- Certain test scripts failed due to strict references to file types rather than Int codes
- Logging into Modo on more than two machines at the same time displayed the wrong error message
- Adding a vertex map texture automatically created a weight map
- Using Replace Icon With Image File in the Preset Browser did not apply image files as thumbnails for .lxo presets
- Adjusting the thumbnail size in the Preset Browser caused Modo to crash
- Applying a Vert Merge and Poly Subdivide positioned geometry incorrectly
- Schematic: Dragging a channel output to another node’s title bar created a green link incorrectly
- Using the Quick Align tool with snapping enabled did not display a gizmo as expected
- Duplicate layered materials referenced from the Library folder did not render correctly
- Child items in the viewport were not updated as expected when the parent was deselected
- The Coplanar Polygons tool did not select all coplanar polygons
- Sliding an edge selection in a certain scene caused Modo to crash
- Importing a mesh containing hidden polygons using layer.import() revealed hidden polygons on the target layer
- Adding a Freeze mesh operation to a certain scene caused Modo to crash
- Zooming out and zooming back in on an object using the Shift+A keyboard shortcut caused the Move tool handles to freeze
- Moving UVs was less responsive than in Modo 13.0 builds
- The Space Navigator rotation override could not be set per viewport
- The option to use the legacy FBX plug-in for import was still accessible in the FBX I/O preferences
- Camera background/foreground images did not work as expected in the path tracer
- Schematic: New nodes could not be connected to existing floating elbows
- Rendering certain scenes in the Preview renderer caused Modo to crash
- Rendering certain scenes using the RTX path tracer caused Modo to become unresponsive
- Mesh Ops: Edge Selection Sets were not preserved on both the source and driver meshes when processed by a Boolean
- Certain legacy scenes did not load as expected in later releases
- Pressing Delete while editing text occasionally deleted the wrong characters or caused Modo to crash
- Curve Fill Holes did not work as expected for curves on the X or Y axes
- Add Layer was occasionally replaced by … (ellipsis) in the UI
- Assigning a Light Path Expression (LPE) to a selected light displayed an error
- Path Tracer: Diffuse coefficient renders produced incorrect output
- Right-clicking on a tool property while editing it occasionally caused Modo to crash
- Mouse scroll did not work as expected in embedded viewports
- Using the Tack tool with Copy Geometry and Make Bridge enabled caused Modo to crash
- Switching from interactive to value sliders did not update the tool handles as expected
- Playblasts did not match the output from the AVP
- Schematic: Links between nodes in the Schematic viewport were occasionally disconnected on load
- Solid Drill slowed down the AVP when a Default material was assigned
- Performing a Merge operation on polygons removed and associated materials
- Performing an undo after using the Mirror tool caused Modo to crash
- Using an Edge Chamfer with profiles did not handle corners well in certain scenarios
- Viewport selection was slower in Modo 13.2 compared to previous versions
- Performing a Jitter mesh operation followed by a Subdivide operation caused the mesh UVs to distort
- When used with area falloffs, the Bevel mesh operation used the BevelVertexWeight() command instead of BevelPolygonWeight() to compute falloffs, which resulted in incorrect weights
- The Transform tool Use World Transform property did not work correctly when using secondary falloffs
- Mix Mode in the Transform tool properties did not work as Use World Transforms did not work correctly when a secondary falloff was added
- Modo did not perform well when removing many edges from a mesh
- Texture Locator transform properties did not update with the correct value at a given frame when scrubbing the timeline
- OCIO settings were not saved between sessions
- Fur could not be rendered in certain scenes
- Axis Slice and other slice mesh operations caused mesh UVs to distort
- The wrong tooltip displayed when the cursor hovered over gang edit icons
- The Modo layout Discard button in the render passes form did not fit on the screen
- Working with command regions in the Advanced viewport became difficult due to the way the regions obscured meshes
- Item shape drawings had additional gamma correction applied in the Advanced viewport
- There was no option to switch automatically from IK to FK on a given frame
- Animation layers did not work with channel based actors
- Mouse and stylus actions could often be interpreted as drag and drop instead of single-click, which resulted in failure of selection redirection or adding commands to items
- Edge Bevel operations caused one polygon to be assigned an incorrect ptag
- Selecting a bezier curve in Polygons selection mode sometimes changed the curve’s shape
- Input fields lost focus if the cursor moved to the top of the screen
- When a non-square image with Use Image Aspect was enabled in the background of the UV viewport, tool handles were drawn incorrectly
- Modo crashed when importing a sub-scene and then performing an undo
- Ignore Scale Groups had no tooltip
- Grease Pencil did not support images with the same aspect ratio as the camera, causing distorted brush shapes
- The Advanced viewport became slow when material display was set to Full
- Rename commands on procedural vertex maps did not work
- The IK solver could not be reset from FK correctly when the IK was using a locator with an up vector
- Edge Chamfer performed poorly in certain scenes
- Bezier effector bends became stepped at extreme values
- Strange refraction behavior occurred in certain scenes using the mPath Renderer
- Loaded image sequences used color management when they should not be color managed
- Textures were re-read on each frame in an animation render causing decreased render performance and increased network traffic
- Bridge with profile set to Reverse Direction used an incorrect Profile
- Vertex Slide did not slide correctly when Merge Vertices was enabled and Stop at Edges was disabled
- In UV view with Inactive disabled and Snapping enabled, you could still see the highlight for inactive meshes
- The UV viewport Backdrop Image property reset between Modo sessions
- Rotating the gizmo in the 3D viewport for the Create UV Map operation caused a drop in performance
- Modo crashed when connecting a mesh to a Weight Map falloff
- Changing texture locator values while previewing in certain scenes caused Modo to crash
- The uv.relax command did not support mode and boundary settings
- AVP did not work with component Selections Transparency settings from the Preferences
- Modo was unstable when using certain internal scene files
- When a weight map was selected, it overrode Ghost and X-Ray view modes in the Vertex Map viewport
- The Multi-cut option of the Edge Slice tool did not work when Work Plane > Lock Plane to Origin was enabled
- AVP: Scenes with a normal map and a metallic constant appear black in the AVP
- The Topology Pen snapped to the background mesh
- AVP: Modo renders handle negative values incorrectly in layer masks
- New features including Unbevel and Partial Element Selection are not accessible from outside the Modo layout
- Modo crashed when setting the Sides property of Lace Geometry to two or below
- Modo locked up when launched for the first time with both plug-ins available and no config.cfg file
- Activating the UV Relax tool with Angle Based mode enabled caused Modo to crash
- The frame rate dropped when playing animations with the Mesh properties visible on the screen
- The Slide tool had inconsistent handles when used in different states
- Rendering an animation auto-saved images when using a Denoiser, which used up a lot of disk space
- Markup had no basic text tool similar to the Modo paint tools
- Markup had no autosave feature
- The render items values did not match the saved values of the imported .lxp presets
- Light linking for mPath renders did not work as expected
- Modo crashed when drawing with the Pen tool in the AVP
- The large icons for Quick Align and Ground Align were incorrect
- Enabling Stacked from the Select Error UVs in the UV layout did not work
- Modo crashed when adding a Merge mesh operation to meshes in certain scenes
- Modo crashed when grouping MeshFusion items together in the Shader Tree
- The Align Center or Align Middle Island commands could not align multiple UV islands in Polygon mode
- Bezier curve based MeshFusion Surface Strips did not create clean strips when underlying primary surfaces had planar changes
- Modo crashed when toggling Enable Embossing in Fusion items for MeshFusion
- Polygon Bevel using Thicken mode failed to output the Front / Back polygon tags
- Modo crashed on first launch when setting Usage Stats to Never
- Modo crashed when enabling Sharp Bezier Corners on bezier curves
- Certain scenes did not release RAM after rendering the scene, causing increased memory usage even after the render had completed
- Editing files on disk did not update the images in the viewport or render windows until Modo was restarted
- In some situations Edge Chamfer produced uneven edges
- Modo crashed after performing an Edge Chamfer in certain scenes
- Modo crashed after performing a cube Boolean operation on a mesh
- Modo crashed when the Fusion Polygon Set was changed from Fusion! To Fusion+
- Modo crashed when quickly selecting different Bridge tool profiles
- Surface Strip creation occasionally failed on MeshFusion items
- Scenes with disabled elbow links reloaded schematic links incorrectly
- Modo crashed when clicking Simulate in certain scenes
- Modo crashed in certain scenes when moving certain polygons
- Enabling Render Curves and triggering a render resulted in a crash
- The Modo introduction screen occasionally failed to load content
- Modo crashed when importing certain .dxf files
- Modo crashed when using the UV Unwrap tool on scenes with degenerated polygons
- The endpoint on closed loops was incorrectly facing the wrong direction
- Modo crashed randomly upon instancing an Assembly
- Solidworks loader DLLs required an update to SW2020
- The Merge command merged bezier control points when it should not
- CloudPreset load: A corrupted .json file caused Modo to crash
- Modo crashed when adding a mesh containing curves as a Surface Strip
- The Recolor To effect in the Shader Tree did not handle oversaturated values consistently between Preview renders, and the Default and Advanced viewports
- Exporting .fbx files did not retain material information
- The mesh had to be selected and deselected in order for command regions to work properly
- Edge Chamfer offset edges asymmetrically
- Enabling Show Selection Normals in the 3D viewport Visibility options, when you had an operation and a face of the base mesh selected, resulted in a crash
- The item.delete item:[name] command did not delete an item unless the item was selected
- Modo crashed when changing the Depth value in the assembly
- Some scenes were too slow to transfer items using the layer.import command
- Image clip previews in the Preset Browser did not update after they were modified on disk
- Radial Sweep did not work as expected with Square enabled on arcs that were less than 360 degrees
- Calling MM_Destroy from a thread caused a crash during ray evaluation
- Edge Align did not always preserve the UV island position in UV space
- Adding mesh operations occasionally caused Modo to crash
- Motion Vector Output rendered curves incorrectly
- Transforming selected UVs dropped the selection
- MeshFusion: Embossing did not work as expected for the letter E
- Importing .fbx files and rearranging the scene caused Modo to crash on exit
- Selecting Render > Render Animation occasionally caused Modo to crash
- Setting a UV space control to a value less than 0.1 did not update the UI correctly
- cloudPB temporary files occasionally caused Modo to crash on restart
- Clicking the spans that close a curve did not select closed B-Spline correctly
- Replica Radial Array did not use item.refSystem() correctly
- Single-sided polygons were displayed as double-sided in the AVP
- Combinations of internal and boundary edges caused Edge Slide to behave erratically
- The Bridge tool did not work as expected with 1D Profiles
- The Pen tool in Polyline and Wall Mode > Both Sides mode only drew on one side
- MeshFusion did not work well with surface strip intersections
- Overlapping area lights in mPath occasionally caused shading artifacts


Join our mailing list

Stay up to date with latest software releases, news, software discounts, deals and more.

Subscribe